通达信低位二次金叉买入指标公式

云财情   2023-01-19 10:49:19   阅读(105)

通达信低位二次金叉买入指标公式 DIFF:Ema(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),LINETHIck0;
DRAWBAND(DIFF,RGB(255,128,192),DEA,RGB(128,255,128));
stICKLINE(MACD>=0,MACD,0,2.5,1),COLORF00FF0;
STICKLINE(MACD< 0,MACD,0,2.5,1),COLORWHITE;
STICKLINE(MACD< REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR00AAFF;
STICKLINE(MACD< REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR00BBFF;
STICKLINE(MACD< REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00CCFF;
STICKLINE(MACD< REF(MACD,1)AND MACD>0,0,MACD,1.5,0 ),COLOR00ddfF;
STICKLINE(MACD< REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00EEFF;
STICKLINE(MACD< REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR0011BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0022CC;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.5,0 ),COLOR0033DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0044EE;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD< 0,0,MACD,2.5,0 ),COLORAA00BB;
STICKLINE(MACD>REF(MACD,1)AND MACD< 0,0,MACD,2.5,0 ),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1)AND MACD< 0,0,MACD,2,0 ),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1)AND MACD< 0,0,MACD,1.5,0 ),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1)AND MACD< 0,0,MACD,1.0,0 ),COLOREE44BB;
STICKLINE(MACD>REF(MACD,1)AND MACD< 0,0,MACD,0.5,0 ),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD< 0,0,MACD,2.5,0 ),COLORFFAA00;
STICKLINE(MACD<=REF(MACD,1)AND MACD< 0,0,MACD,2.5,0 ),COLORFFBB11;
STICKLINE(MACD<=REF(MACD,1)AND MACD< 0,0,MACD,2,0 ),COLORFFCC22;
STICKLINE(MACD<=REF(MACD,1)AND MACD< 0,0,MACD,1.5,0 ),COLORFFDD33;
STICKLINE(MACD<=REF(MACD,1)AND MACD< 0,0,MACD,1,0 ),COLORFFEE44;
STICKLINE(MACD<=REF(MACD,1)AND MACD< 0,0,MACD,0.5,0 ),COLORFFFF55;
IF(DIFF< 0,DIFF,0),COLORRED,LINETHICK2;
IF(DIFF< 0,0,DIFF),COLORYELLOW,LINETHICK2;
IF(DIFF< DEA,DIFF,DEA),COLOR00FF00,LINETHICK2;
IF(DIFF>DEA,DEA,DEA),COLORBLUE,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF< -0.1;
STICKLINE(低位金叉,0,-0.10,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,-0.05,' 低位金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BArslAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA< 0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.10,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.04,13) ;
DRAWTEXT(二次金叉,-0.08,' 二次金叉'),COLORFF00FF;
A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.13,6,0),COLORRED;
DRAWTEXT(底背离,DEA,' 底背离'),COLORRED;
A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A22+1)< CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶背离,DEA,' 顶背离'),COLORGREEN;
A1:=DIFF< 0 AND DEA< 0;
A2:=A1>REF(A1,1);
A3:=BARSLAST(A2);
A4:=COUNT(DEA>0 AND DIFF>0,A3)=0;
A5:=CROSS(DIFF,DEA);
A6:=BARSLAST(A5);
A7:=REF(A6,A6+1)+A6;
A8:=(DIFF+DEA)/2;
A9:=(HIGH+LOW)/2;
A10:=A5 AND A7< A3 AND A4 AND A8>REF(A8,A7) AND A9< REF(A9,A7) AND MACD>0;
DRAWTEXT(A10,DIFF*0.95,'★金叉介入'),COLORYELLOW;
连续走强:BARSLASTCOUNT(MACD>REF(MACD,1) AND MACD>0)NODRAW;
强势回调:BARSLASTCOUNT(MACD< REF(MACD,1) AND MACD>0)NODRAW;
连续走弱:BARSLASTCOUNT(MACD< REF(MACD,1) AND MACD< 0)NODRAW;
连续反弹:BARSLASTCOUNT(MACD>REF(MACD,1) AND MACD< 0)NODRAW;

关键词:
免责声明:本文来自互联网,本站所有信息(包括但不限于文字、视频、音频、数据及图表),不保证该信息的准确性、真实性、完整性、有效性、及时性、原创性等,版权归属于原作者,如无意侵犯媒体或个人知识产权,请来电或致函告之,本站将在第一时间处理。云财情网站发布此文目的在于促进信息交流,不存在盈利性目的,此文观点与本站立场无关,不承担任何责任。未经证实的信息仅供参考,不做任何投资和交易根据,据此操作风险自担。侵权及不实信息举报邮箱至:amarlboro@yeah.net。